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WinsonLib: Arduino Library Application Note 

1. Arduino library installation steps: 

There are two installation methods: 1. download and install on Winson official 

website, 2.use Arduino IDE Library Manager. 

This installation example used the library on the official website of Winson 

company. The library contains the functions of most products developed by 

Winson company, such as WCS, WCM, DWCS and Hall IC, for user 

development. 

Method: 1 

Step 1 : download “WinsonLib” library on the website. 

 

Step 2: generally, the library file (.zip) will be in the default download folder of 

the system. 
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Step 3: enter Arduino IDE and choose Sketch→Include Library 

→Add .ZIP Library... 

 

Step 4: select the library file (.zip) you just downloaded. 
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Step 5: if installation successfully, the example can be found in the Arduino 

IDE : File→Examples→“WinsonLib” (Examples from Custom Libraries). 

 
Step 6: if the example program in the Arduino IDE can be used normally, it 

means that the library is installed correctly. 
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Method: 2 

Step 1: open the Arduino Library Manager : Sketch→Include Library→

Manage Libraries... 

 
Step 2: enter the Library Manager and search: Winson, WCS, WCM or 

DWCS, etc. to find the library “WinsonLib”, and then Install. 

Step 3: use the method to test on the previous page. 
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2. Arduino program execution steps:  

1. Open the Arduino IDE:   

2. Open the program: File→Examples→WinsonLib→DWCS→

Continuous_Mode 

3. Choose the test board: Tools→Board:→Arduino Uno 

4. Choose COM Port: Tools→Port:→COMn 

5. Upload:  

6. Execution results (monitoring window): Tools→Serial Monitor 

 

 

 

<Note> Arduino has only one default serial port (system serial port). This 

example does not use the system serial port (pins 0 and 1), but sets other 

pins as serial ports through the software serial library. Serial Monitor→ Raud 

Rate : 9600 bps 
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3. DWCS: 

The wiring diagram of continuous mode, AT command and Modbus-RTU 

mode (one on one) is as following. Connect the DWCS current sensor to the 

5V power supply. The serial port output pin (TX) of DWCS current sensor 

connects the pin 2 of Arduino, and the zero pin (RX/RST) to the pin 3. 

 

(3.1) Continuous Mode:  

Click on “Continuous_ Mode” example, and upload the program into Arduino. 

The result is shown in the figure below. (DC current 10A) 
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(3.2) AT Command Mode: 

Click on “AT_Command_Mode” example, and upload the program into 

Arduino. The result is shown in the figure below. (DC current 10A) 

 

 

<Note> The code for measuring AC current must be changed. (Default is DC 

current) (#if 1→DC，#if 0→AC) 

DC AC 
#if 1  // 1: DC 
  Serial.print("DC Mode : "); 
  Pass = DWCS.DC(); 
#else 
  Serial.print("AC Mode : "); 
  Pass = DWCS.AC(); 
#endif 

#if 0   // 0: AC 
  Serial.print("DC Mode : "); 
  Pass = DWCS.DC(); 
#else 
  Serial.print("AC Mode : "); 
  Pass = DWCS.AC(); 
#endif 
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(3.3) Modbus-RTU  Mode (one on one): 

Click on “ModbusRTU_SingleDeviceCommunication” example, and upload 

the program into Arduino. The result is shown in the figure below. (DC current 

10A) 

 
<Note>The code for measuring AC current must be changed. (Default is DC 

current) (#if 1→DC，#if 0→AC) 

DC AC 
#if 1   // 1: DC 
  Serial.print("DC Mode : "); 
  Pass = DWCS.DC(); 
  // Pass = DWCS.DC( SlaveAddress); 
#else 
  Serial.print("AC Mode : "); 
  Pass = DWCS.AC(); 
  // Pass = DWCS.AC( SlaveAddress); 
#endif 

#if 0   // 0: AC 
  Serial.print("DC Mode : "); 
  Pass = DWCS.DC(); 
  // Pass = DWCS.DC( SlaveAddress); 
#else 
  Serial.print("AC Mode : "); 
  Pass = DWCS.AC(); 
  // Pass = DWCS.AC( SlaveAddress); 
#endif 

<Note> Modifying the Modbus-RTU address need to change the following 

code. 

#define SlaveAddress 0x01 // Key in SlaveAddress 

                                                 ↳ Modify area, and re-upload 

(3.4) Modbus-RTU  Mode (multipoint): 

First, set the Modbus-RTU Slave address (0x00, 0x01, 0x02) of the three 

DWCS current sensors respectively, as shown in (3.3) Modbus-RTU  Mode 

(one on one), and then click on “ModbusRTU_OneToManyCommunication” 

example, and upload the program into Arduino. Connect the three DWCS 

current sensors to the 5V power supply. The serial port output pin (TX) of the 

three DWCS current sensors connect the pin 2 of Arduino, and serial port 

input pin (RX) to the pin 3, as shown in the following figure. (Sensors 1 and 2 
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pass the DC current 10A, and sensor 3 is not connected) 

 

 

<Note>The code for measuring AC current must be changed. (Default is DC 

current) (#if 1→DC，#if 0→AC) 

DC AC 
#if 1  // 1: DC 
  Serial.print("DC Mode : "); 
  // Pass = DWCS.DC(); 
  Pass = DWCS.DC( PodCast_Address); 
#else 
  Serial.print("AC Mode : "); 
  // Pass = DWCS.AC(); 
  Pass = DWCS.AC( PodCast_Address); 
#endif 

#if 0  // 0: AC 
  Serial.print("DC Mode : "); 
  // Pass = DWCS.DC(); 
  Pass = DWCS.DC( PodCast_Address); 
#else 
  Serial.print("AC Mode : "); 
  // Pass = DWCS.AC(); 
  Pass = DWCS.AC( PodCast_Address); 
#endif 

Use the broadcast address (PodCast_Address) to change all sensors to AC 

or DC current. 
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4. WCM:  

(4.1) Continuous Mode: 

Click on “Continuous_ Mode” example, and upload the program into Arduino. 

Connect the WCM current module to the 5V power supply. The serial port 

output pin (TX) of the WCM current module connects the pin 2 of Arduino, and 

the serial port input pin (RX) to the pin 3, and the zero pin (RST) to the pin 4, 

as shown in the following figure. (DC current 5A) 
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(4.2) Modbus-RTU  Mode (one on one): 

Click on “ModbusRTU_SingleDeviceCommunication” example, and upload 

the program into Arduino. Connect the WCM current module to the 5V power 

supply. The serial port output pin (TX) of the WCM current module connects 

the pin 2 of Arduino, and serial port input pin (RX) to the pin 3, as shown in 

the following figure. (DC current 5A) 

 

 

<Note> Modifying the Modbus-RTU address need to change the following 

code. 

#define SlaveAddress 0x01 // Key in SlaveAddress 

                                                 ↳ Modify area, and re-upload 
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(4.3) Modbus-RTU  Mode (multipoint): 

First, set the Modbus-RTU Slave address (0x00, 0x01, 0x02) of the three 

WCM current modules respectively, as shown in (4.2) Modbus-RTU  Mode 

(one on one), and then click on “ModbusRTU_OneToManyCommunication” 

example, and upload the program into Arduino. Connect the three WCM 

current modules to the 5V power supply. The serial port output pin (TX) of the 

three WCM current modules connect the pin 2 of Arduino, and serial port input 

pin (RX) to the pin 3, as shown in the following figure. (Modules 1 and 2 pass 

the DC current 10A, and Module 3 is not connected) 
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5. WCS:  

(5.1) Single Output: DC: 

Click on “SingleOutput_DC_Current” example, and upload the program into 

Arduino. Connect the WCS current sensor to the 5V power supply. The output 

pin (Vout) of the WCS current sensor connects the analog pin A0 of Arduino, 

as shown in the following figure. 

                                 

(5.2) Differential Output: DC: 

Click on “DifferentialOutput_DC_Current” example, and upload the program 

into Arduino. Connect the WCS current sensor to the 5V power supply. The 

output pin 1(Vout1) of the WCS current sensor connects the analog pin A0 of 

Arduino, and the output pin 2(Vout2) to A1, as shown in the following figure. 
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(5.3) Single Output: AC: 

Click on “SingleOutput_AC_Current” example, and upload the program into 

Arduino. Connect the WCS current sensor to the 5V power supply. The output 

pin (Vout) of the WCS current sensor connects the analog pin A0 of Arduino, 

as shown in the following figure. 

                                           

(5.4) Differential Output: AC: 

Click on “DifferentialOutput_AC_Current” example, and upload the program 

into Arduino. Connect the WCS current sensor to the 5V power supply. The 

output pin 1(Vout1) of the WCS current sensor connects the analog pin A0 of 

Arduino, and the output pin 2(Vout2) to A1, as shown in the following figure. 
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6. Hall IC:  

(6.1) Single Output: Switching:  

Click on “SingleOutput_Switch_IC_Polling” example, and upload the program 

into Arduino. Connect the Hall switching IC to the 5V power supply. The 

output pin (Vout) of the Hall switching IC with external pull-up resistor (1KΩ) 

connects the pin 2 of Arduino, as shown in the following figure. 

 

(6.2) Dual Output: Switching:  

Click on “DualOutput_Switch_IC_Polling” example, and upload the program 

into Arduino. Connect the Hall switching IC to the 5V power supply. All the 

output pins of the Hall switching IC pull up resistor (1KΩ) respectively. The 

output pin 1(Vout1) of the Hall switching IC connects the pin 2 of Arduino, and 

the output pin 2(Vout2) to the pin 3, as shown in the following figure. 
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7. Function Description 

(7.1) DWCS Class 

1. DWCS( byte Tx, byte Rx, Wtype_t Mode) 

Description:  

DWCS: initialize DWCS Class (Continuous Mode, AT Command Mode) 

Tx: DWCS TX Pin 

Rx: DWCS RX Pin 

Mode: AC, DC, AT Mode 

Example:  

DWCS DWCS (2, 3, AC); 

 

2. DWCS( byte Tx, byte Rx, Wtype_t Mode, byte SlaveAddress) 

Description:  

DWCS: initialize DWCS Class (Modbus-RTU Mode) 

Tx: DWCS TX Pin 

Rx: DWCS RX Pin 

Mode: Modbus Mode 

SlaveAddress: Modbus-RTU slave address 

Example:  

DWCS DWCS (2, 3, Modbus, 0x01); 

 

3. void Init() 

Description:  

Initialize DWCS. 

Example:  

DWCS.init(); 

 

4. double mA() 

Description:  

Measure current, unit: mA. 

Example:  

data = DWCS.mA(); 
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5. double mA( byte SlaveAddress) 

Description:  

Measure current according to Modbus-RTU slave address, unit: mA. 

SlaveAddress: Modbus-RTU slave address 

Example:  

data = DWCS.mA(0x01); 

 

6. double A() 

Description:  

Measure current, unit: A. 

Example:  

data = DWCS.A(); 

 

7. double A( byte SlaveAddress) 

Description:  

Measure current according to Modbus-RTU slave address, unit: A. 

SlaveAddress: Modbus-RTU slave address 

Example:  

data = DWCS.A(0x01); 

 

8. double oC() 

Description:  

Measure temperature, unit: °C. 

Example:  

data = DWCS.oC(); 

 

9. double oC( byte SlaveAddress) 

Description:  

Measure temperature according to Modbus-RTU slave address, unit: °C. 

SlaveAddress: Modbus-RTU slave address 

Example:  

data = DWCS.oC(0x01); 
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10.  double oF() 

Description:  

Measure temperature, unit: °F. 

Example:  

data = DWCS.oF(); 

 

11.  double oF( byte SlaveAddress) 

Description:  

Measure temperature according to Modbus-RTU slave address, unit: °F. 

SlaveAddress: Modbus-RTU slave address 

Example:  

data = DWCS.oF(0x01); 

 

12.  bool Reset() 

Description:  

Reset current. 

Example:  

DWCS.Reset(); 

 

13.  bool Reset ( byte SlaveAddress) 

Description:  

Reset current according to Modbus-RTU slave address. 

SlaveAddress: Modbus-RTU slave address 

Example:  

DWCS.Reset(0x01); 

 

14.  bool DC() 

Description:  

Switch DC current. 

Example:  

DWCS.DC(); 
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15.  bool DC ( byte SlaveAddress) 

Description:  

Switch DC current according to Modbus-RTU slave address. 

SlaveAddress: Modbus-RTU slave address 

Example:  

DWCS.DC(0x01); 

 

16.  bool AC() 

Description:  

Switch AC current. 

Example:  

DWCS.AC(); 

 

17.  bool AC ( byte SlaveAddress) 

Description:  

Switch AC current according to Modbus-RTU slave address. 

SlaveAddress: Modbus-RTU slave address 

Example:  

DWCS.AC( 0x01); 

 

18.  bool SetAddress( byte SlaveAddress) 

Description:  

Change the new Modbus-RTU slave address according to present slave 

address. 

SlaveAddress: Modbus-RTU slave address 

Example:  

DWCS.SetAddress(0x02); 

 

19.  bool SetAddress( byte OldAddress, byte NewAddress) 

Description:  

Specify Modbus-RTU slave address and replace with a new slave address. 

OldAddress: old Modbus-RTU slave address 

NewAddress: new Modbus-RTU slave address 

Example:  

DWCS.SetAddress( 0x00, 0x02); 
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20.  bool FactoryReset() 

Description:  

Restore factory Modbus-RTU slave address (0x01). 

<Note> This command uses podcast address (0x00), it is recommended to 

use single sensor for setting. 

Example:  

DWCS. FactoryReset(); 

 

21.  byte addr() 

Description:  

Read Modbus-RTU Slave Address. 

Example :  

address = DWCS. addr(); 

 

(7.2) WCM Class 

1. WCM( byte Tx, byte Rx, Wtype_t Mode) 

Description:  

WCM: initialize WCM Class (Continuous Mode) 

Tx: WCM TX Pin 

Rx: WCM RX Pin 

Mode: AC, DC, ACDC Mode 

Example:  

WCM WCM (2, 3, ACDC); 

 

2. WCM( byte Tx, byte Rx, byte Rst, Wtype_t Mode, byte SlaveAddress) 

Description:  

WCM: initialize WCM Class (Modbus-RTU Mode) 

Tx: WCM TX Pin 

Rx: WCM RX Pin 

Rst: WCM RST Pin 

Mode: Modbus Mode 

SlaveAddress: Modbus-RTU slave address 

Example:  

WCM WCM (2, 3, 4, Modbus, 0x01); 
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3. void Init() 

Description:  

Initialize WCM. 

Example:  

WCM.init(); 

 

4. double mA() 

Description:  

Measure current, unit: mA. 

Example:  

data = WCM.mA(); 

 

5. double mA( byte SlaveAddress) 

Description:  

Measure current according to Modbus-RTU slave address, unit: mA. 

SlaveAddress: Modbus-RTU slave address 

Example:  

data = WCM.mA( 0x01); 

 

6. double A() 

Description:  

Measure current, unit: A. 

Example:  

data = WCM.A(); 

 

7. double A( byte SlaveAddress) 

Description:  

Measure current according to Modbus-RTU slave address, unit: A. 

SlaveAddress: Modbus-RTU slave address 

Example:  

data = WCM.A( 0x01); 
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8. double oC() 

Description:  

Measure temperature, unit: °C. 

Example:  

data = WCM.oC(); 

 

9. double oC( byte SlaveAddress) 

Description:  

Measure temperature according to Modbus-RTU slave address, unit: °C. 

SlaveAddress: Modbus-RTU slave address 

Example:  

data = WCM.oC( 0x01); 

 

10. double oF() 

Description:  

Measure temperature, unit: °F. 

Example:  

data = WCM.oF(); 

 

11. double oF( byte SlaveAddress) 

Description:  

Measure temperature according to Modbus-RTU slave address, unit: °F. 

SlaveAddress: Modbus-RTU slave address 

Example:  

data = WCM.oF( 0x01); 

 

12. bool Reset() 

Description:  

Reset current. 

Example:  

WCM. Reset(); 
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13. bool Reset ( byte SlaveAddress) 

Description:  

Reset Current according to Modbus-RTU slave address. 

SlaveAddress: Modbus-RTU slave address 

Example:  

WCM.Reset( 0x01); 

 

14. bool SetAddress( byte SlaveAddress) 

Description:  

Change the new Modbus-RTU slave address according to present slave 

address. 

Example:  

WCM.SetAddress( 0x02); 

 

15. bool SetAddress( byte OldAddress, byte NewAddress) 

Description:  

Specify Modbus-RTU slave address and replace with a new slave address. 

OldAddress: old Modbus-RTU slave address 

NewAddress: new Modbus-RTU slave address 

Example:  

WCM.SetAddress( 0x00, 0x02); 

 

16. bool FactoryReset() 

Description:  

Restore factory Modbus-RTU slave address (0x01). 

<Note> This command uses podcast address (0x00), it is recommended to 

use single sensor for setting. 

Example:  

WCM. FactoryReset(); 

 

17. byte addr() 

Description:  

Read Modbus-RTU slave address. 

Example:  

address = WCM. addr(); 
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(7.3) WCS Class 

1. WCS(uint8_t analogPin, uint16_t mVperA) 

Description:  

WCS: initialize WCS Class (Single Output Mode) 

analogPin: WCS output pin 

mVperA: WCS sensitivity (as shown in table) 

mVperA Sensitivity (mV/A) mVperA Sensitivity (mV/A) 

_WCS1500 11 _WCS3740 32 

_WCS1600 22 _WCS2750 32 

_WCS1700 33 _WCS2720 65 

_WCS1800 66 _WCS2810 135 

_WCS6800 65 _WCS2705 260 

_WCS2800 70 _WCS2702 1000 

_WCS2200 140 _WCS2801 2000 

_WCS2210 280 _WCS37A50 3500 

_WCS2202 1120 _WCS38A25 7000 

_WCS2201 4200   

<Note> you can also enter the value directly. 

Example:  

WCS WCS (0, _WCS1800); 

WCS WCS (0, 66); 

 

2. WCS(uint8_t analogPin, uint8_t analogPin2, uint16_t mVperA) 

Description:  

WCS: initialize WCS Class (Differential Output) 

analogPin: WCS output pin 1 

analogPin2: WCS output Pin 2 

mVperA: WCS sensitivity (as shown in table) 

Example:  

WCS WCS (0, 1, _WCS2200); 

 

3. void Reset() 

Description:  

Reset current. 

Example:  

WCS.Reset(); 
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4. double A_AC() 

Description:  

Measure AC current. 

Example:  

data = WCS.A_AC(); 

 

5. double A_DC() 

Description:  

Measure DC current. 

Example:  

data = WCS.A_DC(); 

 

 


